Författare Ämne: Länkar stöder inte ÅÄÖ?  (läst 1796 gånger)

John

  • Jr. Member
  • **
  • Antal inlägg: 58
    • Visa profil
Länkar stöder inte ÅÄÖ?
« skrivet: 2018-08-26, 12:47:24 PM »
Hej! Jag är en ny släktforskare och användare av Genney - som jag tycker är väldans bra. Har dock lite småproblem.
Om jag har en extern länk som innehåller tex ett ä så ser (ett utdrag från) länken ut så här:
Pias%20släkt
Men när jag skapar en ny mediafil, väljer webadress och klistrar in länken så kodas den om till:
Pias%20sl%C3%A4kt
Och det funkar ju naturligtvis inte då. Väljer jag att mata in korrekt adress för hand så får jag bara meddelandet "ogiltig adress".
Gäller förmodligen åäö.
Dessvärre är det likadant om man klistrar in en länk i en anteckning också.
« Senast ändrad: 2018-08-26, 18:26:10 PM av John »

Administrator

  • Administrator
  • Hero Member
  • *****
  • Antal inlägg: 2030
    • Visa profil
SV: Länkar stöder inte ÅÄÖ?
« Svar #1 skrivet: 2018-08-27, 07:34:34 AM »
Omkodningen sker inte i Genney utan i det program från vilket du kopierat länken, kan du ge ett fullt exempel på en fungerande länk av det slaget?

Pias%20släkt är en blandning av URL Encoding och typ UTF-8 vilket ser inkonsekvent ut, https://www.w3schools.com/tags/ref_urlencode.asp.

John

  • Jr. Member
  • **
  • Antal inlägg: 58
    • Visa profil
SV: Länkar stöder inte ÅÄÖ?
« Svar #2 skrivet: 2018-08-27, 18:29:01 PM »
Märkte att det inte bara var åäö utan det är även mellanslag som kodas olika.
Här är ett exempel på en länk (dock inte till min sida eftersom den är lösenordsskyddad)
Den fungerar utmärkt att mata in i en webläsare men inte i Genney , som länk. Min sida är även den gjord med jAlbum precis som exemplet här.

Det är någon/något, Genney eller webläsaren, som kodar om % (i %20 - som ju är mellanslag)  till %25 så följden blir %2520. (Blev en rätt knepig rad där).

http://samples.jalbum.net/Social%20integration/Objects/index.html
« Senast ändrad: 2018-08-27, 18:47:44 PM av John »

Administrator

  • Administrator
  • Hero Member
  • *****
  • Antal inlägg: 2030
    • Visa profil
SV: Länkar stöder inte ÅÄÖ?
« Svar #3 skrivet: 2018-08-27, 19:36:28 PM »
Ok, nu är jag med.

Url:en http://samples.jalbum.net/Social integration/Objects/index.html öppnar inte sidan i webbläsaren vilket http://samples.jalbum.net/Social%20integration/Objects/index.html gör och den kodas när den ska öppnas webbläsaren. Jag är osäker på var det händer för det är i kommunikationen mellan java och webbläsaren och det går inte att se och sker då med alla berörda tecken.

Skriver man in http://samples.jalbum.net/Social%20integration/Objects/index.html så kommer % att kodas om till %25 så det man skulle skriva i texten för att det skulle bli rätt är http://samples.jalbum.net/Social integration/Objects/index.html. Problemet då är att det blir svårt (om det ens är möjligt) att skilja ut från efterföljande text, som är separerad med mellanslag, med regex. Vilket blir tydligt i länken här i inlägget som bryts vid mellanslaget.

Störande är att http://samples.jalbum.net/Social+integration/Objects/index.html varken kodas om eller öppnas i webbläsaren i det här fallet.

Möjligen skulle det fungera att Genney avkodar url:er innan man skickar url:en till webbläsaren.
« Senast ändrad: 2018-08-27, 19:56:46 PM av Administrator »

John

  • Jr. Member
  • **
  • Antal inlägg: 58
    • Visa profil
SV: Länkar stöder inte ÅÄÖ?
« Svar #4 skrivet: 2018-08-27, 20:10:21 PM »
Ja, det är störande. Speciellt när jag kom på den brillianta idén att länka till bilder på min hemsida från Genney......och så funkar det inte. Inte hela världen men det hade varit snitsigt!

Administrator

  • Administrator
  • Hero Member
  • *****
  • Antal inlägg: 2030
    • Visa profil
SV: Länkar stöder inte ÅÄÖ?
« Svar #5 skrivet: 2018-08-27, 20:17:50 PM »
Varför inte utesluta mellanslag i sökvägar och i filnamn, vilket generellt är en bra idé?
« Senast ändrad: 2018-08-27, 20:21:25 PM av Administrator »

John

  • Jr. Member
  • **
  • Antal inlägg: 58
    • Visa profil
SV: Länkar stöder inte ÅÄÖ?
« Svar #6 skrivet: 2018-08-27, 20:25:52 PM »
Jo, jag vet. Men saken är den att bilderna som är publicerade på webben är baserat på en mappstruktur i datorn (som jAlbum använder direkt för publicering). Ser riktigt tråkigt ut och är svårläst i en meny med t.ex farmorochfarfar istället för "farmor och farfar".

Administrator

  • Administrator
  • Hero Member
  • *****
  • Antal inlägg: 2030
    • Visa profil
SV: Länkar stöder inte ÅÄÖ?
« Svar #7 skrivet: 2018-08-27, 20:34:02 PM »
farmor_och_farfar?
« Senast ändrad: 2018-08-27, 20:36:18 PM av Administrator »

John

  • Jr. Member
  • **
  • Antal inlägg: 58
    • Visa profil
SV: Länkar stöder inte ÅÄÖ?
« Svar #8 skrivet: 2018-08-27, 20:40:46 PM »
Du skulle bara veta hur mycket jag behöver ändra samt skicka upp igen. Men fortfarande - det är ju ett problem för andra också. Man kan ju t.ex. ha referenser/källor som inte går att lägga in mm. Jag kan fixa mina egna sidor men det är ju värre med andras.
« Senast ändrad: 2018-08-27, 21:58:49 PM av John »

Administrator

  • Administrator
  • Hero Member
  • *****
  • Antal inlägg: 2030
    • Visa profil
SV: Länkar stöder inte ÅÄÖ?
« Svar #9 skrivet: 2018-08-28, 07:20:41 AM »
Kan hålla med, jag ska se vad jag kan göra, det borde fungera att först avkoda och sen koda för att få en fungerande url.
« Senast ändrad: 2018-08-28, 07:25:43 AM av Administrator »

John

  • Jr. Member
  • **
  • Antal inlägg: 58
    • Visa profil
SV: Länkar stöder inte ÅÄÖ?
« Svar #10 skrivet: 2018-08-28, 18:58:21 PM »
Låter bra. Tack så länge....

John

  • Jr. Member
  • **
  • Antal inlägg: 58
    • Visa profil
SV: Länkar stöder inte ÅÄÖ?
« Svar #11 skrivet: 2019-01-02, 21:41:46 PM »
Ser ut som att det funkar som det ska i v2.1. Det jag saknar nu är att man ska kunna använda hyperlänkar i tex anteckningar.
Använder man istället media och väljer url så får man en lång sträng med webadressen och det blir ju inte så snyggt i biografin på en publicerad sida. Hade ju varit bra med ett val "hyperlänk" så adressen doldes. För jag kan ju tänka mig att man vill ha med den vid pappersutskrifter men inte på nätet.
Eller finns det förslag på hur man kan göra istället?
« Senast ändrad: 2019-01-04, 18:14:39 PM av John »